This project has moved and is read-only. For the latest updates, please go here.

Boy I looked for an hour before writing this.

Aug 6, 2015 at 2:50 AM
I have written a 12,000 line 3D Shell designer for HPVs (Human Powered Vehicles). I used VS2010 because that's the last version that works with XNA (my rendering interface to DirectX) w/o kluges.

Your documentation does say it supports 2010 but I'm a bit stuck in this version for the target project (not the example, I could use 2008 or 2012 for the example, something I did not try).

I do reference the 4.0 .Net framework and have all the C++ dlls for 2008 thru 2012 installed.

I tried referencing the Runtime Version 4.0.30319 of:


When that errored, I tried the 2.0 "just cuz" but got the same error.

The program errors on the dll load when I try to convert a jpg to a pdf:

Could not load file or assembly 'Magick.NET-x64, Version=, Culture=neutral, PublicKeyToken=2004825badfa91ec' or one of its dependencies. An attempt was made to load a program with an incorrect format.

Anything I can do to fix that? Apologize for the hassle.
Aug 6, 2015 at 2:51 AM
Oops I meant to say your documentation DOES NOT say it supports VS2010. Sorry about that.
Aug 6, 2015 at 11:51 AM
Your error is not related to Magick.NET. You are trying to load an 64-bit assembly in a 32-bit application pool. You should take a look at your project settings.
Aug 6, 2015 at 1:20 PM
Thank you dlemstra, I would like to donate. It still does not work when I open the pdf (says an error) but I'll work on that. Probably some setting about resolution or something. At least it writes the PDF.

I'd prefer to just use PayPal. Probably some way we can work out the details behind the scene.
Aug 6, 2015 at 1:47 PM
Edited Aug 6, 2015 at 1:48 PM
Did you install Ghostscript? This is required to process PDF files.

You can contact me through CodePlex here: and we can work out the details there.
Aug 6, 2015 at 5:12 PM
I thought Ghostscript was only for processing the other way (i.e. from PDF to "something else" or interpreting the PDF data... or something, just "the other way").

Didn't think I needed it to write a PDF.
Aug 6, 2015 at 6:33 PM
I misunderstood your remark about not being able to open the file. I thought you tried to open a PDF file but you are only writing it. Feel free to ask more questions if you cannot open the PDF and need more help. Please include a link to your input file(s) and a small example to reproduce the issue.
Aug 7, 2015 at 5:13 PM
Didn't get a chance to look at it yesterday but tried it just now and the PDF loads just fine. Zero changes, no idea although I did see that someone else had remarked the same thing I saw "...tried it later and it worked, no idea why...". There's only 10 or so total lines in the program. The lines of interest:

using (MagickImage image = new MagickImage(AppPath + "RedRocket.jpg"))
            // Create pdf file with a single page
                image.Write(AppPath + "RedRocket.pdf");
(catch block follows, it has never hit the catch).
Aug 7, 2015 at 6:35 PM
I am happy to hear that it worked and thank you for the donation to this project.