This project has moved and is read-only. For the latest updates, please go here.

Fonts not being used when using Pango

Jul 1, 2014 at 10:35 PM
I'm using pango to generate some text on a server. When I run it from my local machine, or in the context of my user name on the server, everything runs fine.

However when the image is generated on an IIS site, or from a task run under the context of a system account with less privlages. It falls back to a different font. It seems to be an issue of rights, but I don't even know where to begin to check.
Jul 1, 2014 at 11:08 PM
How are you referencing the fonts? Do you have a small code example?
Jul 2, 2014 at 1:38 PM
It had nothing to do with, or my rights.

I added new fonts (Pango doesn't seem to be able to use font files when I specify the path) to Windows\Fonts. IIS and the Task Manager are always running. So they weren't aware of the new fonts. Rebooting the server did the trick, though restarting those services would've probably worked too.