This project has moved. For the latest updates, please go here.

Magick.NET.Core is not compatible with UWP app

Mar 8, 2016 at 10:33 AM
I am developing an UWP app with following information:
  • Target: Universal Windows
  • Target Version: Windows 10 (10.0; Build 10586)
I tried to install Magick.NET.Core-Q8 (Version: 7.0.0.103) to my app by using Nuget Package Manager but I got these error messages:
Restoring packages for 'EditPhotoUWP'.
Restoring packages for D:\WorkSpace\Visual Studio\EditPhotoUWP\EditPhotoUWP\project.json...
Magick.NET.Core-Q8 7.0.0.103 is not compatible with UAP,Version=v10.0.
Some packages are not compatible with UAP,Version=v10.0.
Magick.NET.Core-Q8 7.0.0.103 is not compatible with UAP,Version=v10.0 (win10-arm).
Some packages are not compatible with UAP,Version=v10.0 (win10-arm).
Magick.NET.Core-Q8 7.0.0.103 is not compatible with UAP,Version=v10.0 (win10-arm-aot).
Some packages are not compatible with UAP,Version=v10.0 (win10-arm-aot).
Magick.NET.Core-Q8 7.0.0.103 is not compatible with UAP,Version=v10.0 (win10-x86).
Some packages are not compatible with UAP,Version=v10.0 (win10-x86).
Magick.NET.Core-Q8 7.0.0.103 is not compatible with UAP,Version=v10.0 (win10-x86-aot).
Some packages are not compatible with UAP,Version=v10.0 (win10-x86-aot).
Magick.NET.Core-Q8 7.0.0.103 is not compatible with UAP,Version=v10.0 (win10-x64).
Some packages are not compatible with UAP,Version=v10.0 (win10-x64).
Magick.NET.Core-Q8 7.0.0.103 is not compatible with UAP,Version=v10.0 (win10-x64-aot).
Some packages are not compatible with UAP,Version=v10.0 (win10-x64-aot).
Package restore failed for 'EditPhotoUWP'.
Package restore failed. Rolling back package changes for 'EditPhotoUWP'.
Does Magick.NET support UWP apps? If not, are there any ways to use this library in an UAP app?
Coordinator
Mar 8, 2016 at 9:07 PM
Magick.NET.Core is very new and I haven't tried to get it working on UWP. It looks like it is not possible at the moment but it think it should be possible. I am now installing the tools to create UWP apps in Visual Studio and I will give it a try. I cannot tell you when I will be able to work on this. I will get back to this topic when I know more.
Coordinator
Mar 11, 2016 at 9:34 AM
Edited Mar 11, 2016 at 9:48 AM
I will pick this up at a later moment (not sure when). I just did a quick try to see if I could change Core to use netstandard instead of dotnet but I am unable to get it to work.
Mar 12, 2016 at 9:38 AM
Thank for your quick response! I am looking forward to your update!